Qemu mouse lag

By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service. The dark mode beta is finally here. Change your preferences any time. Stack Overflow for Teams is a private, secure spot for you and your coworkers to find and share information.

Subscribe to RSS

First: mouse is slow it lags behind movement and I see the most mouse. That means every time I move, first I see host mouse moving and then guest mouse slowly gets under it. Second: keyboard doesn't handle holding keys well. So let's say I press 'a' for several seconds. Normally I would expect a's to be typed every x miliseconds. In QEMU, only one a is written at start, and only when I release the key, all others are written at once.

Is it a common problem and is there some solution? Maybe some guest drivers? But I have only found too difficult tutorials to install Spice, so if you know about understandable one, please point me to it. Please see this articleit helped me fixing a similar problem few weeks ago. Learn more. Asked 4 years, 11 months ago.

Active 1 year, 1 month ago. Viewed 8k times. But I have only found too difficult tutorials to install Spice, so if you know about understandable one, please point me to it Thanks for any useful advice. Juraj Juraj 2 2 silver badges 11 11 bronze badges. Active Oldest Votes. Eugen Mihailescu Eugen Mihailescu 2, 1 1 gold badge 23 23 silver badges 27 27 bronze badges. Thanks, the thing with registry helped with the keyboard problem. But mouse still lags and I see a host mouse.

Thanks for suggestion Eugen. Actually trying to install virtio was one of things I wanted to achieve. I tried installers from alt.

Could you point me to some up-to-date tutorial how to install it? There is nothing wrong with your virtio installation. The thing is that when you switch your bus from IDE to virtio the Windows doesn't know how to handle the new driver. My trick was to install the virtio driver first and only then to switch your disk bus to virtio. To do that just create an additional 1MB disk and set virtio as bus type. Then while on Windows install the virtio driver.

Then power-off, switch entirely your disk buses to virtio and you are good to go. Sign up or log in Sign up using Google. Sign up using Facebook. Sign up using Email and Password.Welcome to LinuxQuestions.

You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!

Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. Are you new to LinuxQuestions. If you need to reset your password, click here. Having a problem logging in?

Please visit this page to clear all LQ-related cookies. Introduction to Linux - A Hands on Guide This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter. For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration.

This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own. Click Here to receive this Complete Guide absolutely free. Need help with QEMU mouse lag and freeze makes it unusable. I have a Core 2 e OC'd to 3. I used qemu-img creator to install XP SP3. Right now I'm just running it pretty bare "qemu-kvm -m winxp.

It took me a good minute of fiddling with the cursor just to get to the start button.

How To Fix Mouse Lag and Keyboard Lag. Fix Wireless Mouse Lag with this easy fix for Mac or PC

I tried using the option "-usbdevice tablet" this was recommended somewhere else Are there other things I can try?Red Hat Associate. Red Hat Customer. Browse Requests Reports Product Dashboard. Page Help! This site requires JavaScript to be enabled to function correctly, please enable it.

Note You need to log in before you can comment on or make changes to this bug.

Keywords :. If docs needed, set a value. Attachments Terms of Use Add an attachment proposed patch, testcase, etc. Description Tom Horsley UTC Description of problem: Some very recent update has made my Windows 10 virtual machine utterly unusable with the mouse pointer, and whatever it is seems to leak out of the virtual machine and make other windows on my host machine go funny in the head as well.

I submit this against qemu only because I have no real idea where to actually file it or what is really busted. Version-Release number of selected component if applicable : qemu-system-x Steps to Reproduce: 1. Actual results: Hopeless Expected results: Mouse as smooth as it is in other virtual machines Additional info: I have used this machine as recently as a few days ago with no problems, so something new has happened. I even went back to a December version of the Windows 10 image file and it has the same problems now even though it obviously has no new Windows 10 updates in it.

The most recent updates that might be relevant are a new kernel and new virt-manager that were just installed yesterday, so perhaps I should have picked one of them for this bug. Comment 1 Tom Horsley UTC OK, it was simple to try booting into the old kernel, and when I do that, the Windows 10 mouse movement is perfectly smooth, so I'm changing the component of this bug to kernel. I have no idea why only Windows 10 is leaking out through the QXL driver, but whatever is going on appears to be in the kernel.

When booted in kernel But in both kernels the mouse pointer is perfectly fine in Windows XP and Centos virtual machines. Perhaps that will provide a clue I just got a GTX card and when I booted the 4. I don't know if that means the component of this bug should change to the xorg-xdrv-intel driver or not because the same intel driver has no problems in the 4. Comment 5 Tom Horsley UTC One more datapoint probably no one cares about: The nvidia binary drivers also run the cursor perfectly normally in the virtual machine.I have no such issues with VirtualBox.

Reading the Fedora documentation it seems the virtio-win package is supposed to be installed on the host? From VirtualBox, I thought guest-additions get installed… in the guest. So I have to install the virtio-win package in Fedora host and also install which? The VM disk image was made by, and still used with, VirtualBox, though not simultaneously. Would the virtio drivers and VirtualBox guest additions conflict?

However this only applies if you setup any virtio devices via virt manager for example in the first place. Have a look in windows device manager on the guest and see if there are any devices that are missing drivers.

Ok, after rereading the documentation I think I understand a little more. Also, I did not see any of the other devices for which the documentation mentioned installing drivers. Are the options in virt-manager explained and discussed anywhere? For example the disk bus was set up as IDE. Aaaand right after typing all that I semi-solved it: installing QXL drivers for the display adapter worked.

Mouse pointer and video playback are much much smoother now. But… playing HD still drops a lot of frames, while VirtualBox has no issues. Return to Level1Techs. Did you install the virtio windows guest drivers? Which devices need virtio drivers? Can multiple drivers be installed for the same devices? Also, can VirtualBox snapshots work with virt-manager? Have a look in windows device manager on the guest and see if there are any devices that are missing drivers Aside from that, look what happens if you add a USB mouse device in addition the usual default PS2 device that Virt Manager uses.

Now, is there anything like seamless mode?Review your favorite Linux distribution. Welcome to LinuxQuestions. You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today! Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.

KVM virtualization with VMM/virt-manager and mouse lag and stutter

Are you new to LinuxQuestions. If you need to reset your password, click here. Having a problem logging in? Please visit this page to clear all LQ-related cookies. Introduction to Linux - A Hands on Guide This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter.

KVM virtualization with VMM/virt-manager and mouse lag and stutter

For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration.

This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant.

They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own. Click Here to receive this Complete Guide absolutely free. Need help with QEMU mouse lag and freeze makes it unusable. I have a Core 2 e OC'd to 3. I used qemu-img creator to install XP SP3.

Right now I'm just running it pretty bare "qemu-kvm -m winxp. It took me a good minute of fiddling with the cursor just to get to the start button. I tried using the option "-usbdevice tablet" this was recommended somewhere else Are there other things I can try? Also I'm using Slackware The kernel uses the standard generic configuration that ships with Slackware. Last edited by narz; at AM. Ok I figured out the issue. It's the GTK display that was causing it. I set to display to SDL and it works good now.

Thread Tools. BB code is On. Smilies are On. All times are GMT The time now is AM. Open Source Consulting Domain Registration.By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service.

The dark mode beta is finally here. Change your preferences any time. Stack Overflow for Teams is a private, secure spot for you and your coworkers to find and share information. First: mouse is slow it lags behind movement and I see the most mouse.

That means every time I move, first I see host mouse moving and then guest mouse slowly gets under it. Second: keyboard doesn't handle holding keys well. So let's say I press 'a' for several seconds. Normally I would expect a's to be typed every x miliseconds.

In QEMU, only one a is written at start, and only when I release the key, all others are written at once. Is it a common problem and is there some solution?

Maybe some guest drivers? But I have only found too difficult tutorials to install Spice, so if you know about understandable one, please point me to it. Please see this articleit helped me fixing a similar problem few weeks ago.

Learn more. Asked 5 years ago. Active 1 year, 2 months ago. Viewed 8k times. But I have only found too difficult tutorials to install Spice, so if you know about understandable one, please point me to it Thanks for any useful advice. Juraj Juraj 2 2 silver badges 11 11 bronze badges. Active Oldest Votes. Eugen Mihailescu Eugen Mihailescu 2, 1 1 gold badge 23 23 silver badges 27 27 bronze badges. Thanks, the thing with registry helped with the keyboard problem.

But mouse still lags and I see a host mouse. Thanks for suggestion Eugen. Actually trying to install virtio was one of things I wanted to achieve. I tried installers from alt. Could you point me to some up-to-date tutorial how to install it? There is nothing wrong with your virtio installation.

The thing is that when you switch your bus from IDE to virtio the Windows doesn't know how to handle the new driver. My trick was to install the virtio driver first and only then to switch your disk bus to virtio. To do that just create an additional 1MB disk and set virtio as bus type. Then while on Windows install the virtio driver. Then power-off, switch entirely your disk buses to virtio and you are good to go.

qemu mouse lag

Sign up or log in Sign up using Google.Forums New posts Search forums. What's new New posts Latest activity. Members Current visitors New profile posts Search profile posts.

qemu mouse lag

Log in. Search Everywhere Threads This forum This thread. Search titles only. Search Advanced search…. Everywhere Threads This forum This thread. Search Advanced…. New posts. Search forums.

qemu mouse lag

Thread starter rumble06 Start date Jul 16, JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding. Jul 12, 14 0 1 I have an USB audio interface, using the usb passthrough I get crackling noise whenever sound specially louder ones is played. What I am looking is a way to make the usb port s passthrough more efficiently. Feb 1, 4, 31 Vienna. Last edited: Jul 16, You must log in or register to reply here. Share: Email Link. Top Bottom. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.

By continuing to use this site, you are consenting to our use of cookies. Accept Learn more….